Software incompatible con las versiones más recientes del sistema operativo

Compré una nueva computadora para replace mi vieja MacBook Air (2011). Migré desde mi copy de security de Time Machine, trayendo mis aplicaciones antiguas. Uno de los pasos en la migration decía "identificar software incompatible".

Algunas aplicaciones tienen un círculo gris cortado sobre ellas, mientras que otras (como OmniGraffle 4) simplemente se bloquean instantáneamente al iniciarse.

  • ¿Cuál es el mejor NAS para uso doméstico con Macs?
  • Cámara web HD para iChat
  • Problemas al instalar versiones de Ruby a través de RVM en Mountain Lion
  • Mini cable de puerto de pantalla y compatibilidad con el cable Thunderbolt
  • ¿Puedo conectar en cadena varias pantallas con Thunderbolt?
  • Cómo instalar aplicaciones que requieren una versión más nueva de iOS en una primera generación. iPad?
  • ¿Qué causa que algunas aplicaciones sean preidentificadas como incompatibles mientras que otras simplemente no funcionan?

  • ¿Cómo puedo ejecutar Warcraft III (una aplicación PowerPC) en OS X Mountain Lion?
  • ¿Cómo veo files .wtv en OS X?
  • ¿Cuál es el mejor NAS para uso doméstico con Macs?
  • Instale OS X anterior en la última Mac Mini
  • Mini cable de puerto de pantalla y compatibilidad con el cable Thunderbolt
  • ¿Todos los accesorios de iPhone / iPod son compatibles con iPad?
  • One Solution collect form web for “Software incompatible con las versiones más recientes del sistema operativo”

    ¿Qué causa que algunas aplicaciones se identifiquen previamente como incompatibles mientras que otras simplemente no funcionan?

    Todo depende. Algunos binarys se comstackn con un indicador que indica cuál es la versión mínima del sistema operativo en la que se ejecutará. También está el Info.plist que contiene versiones mínimas del sistema operativo. Finalmente, la aplicación en sí puede verificar si se ejecutará en una versión de sistema operativo en particular.

    Lamentablemente, las aplicaciones más antiguas como OmniGraffe 4, que se lanzó en 2005, probablemente no utilicen ninguna de las versiones (y son incompatibles), por lo que se bloquea al iniciarse.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).