rbenv no supera el valor pnetworkingeterminado Versión Ruby

Utilicé la escritura del orderador portátil del thoughtbot para fijar un nuevo air de Macbook (OSX 10.10.5), pero cuando navego dentro de un proyecto de los carriles que contiene un .ruby-version , ejecutando commands tales como rails s devuelve un error de: Your Ruby version is 2.0.0, but your Gemfile specified 2.2.3 .

Ejecutar rbenv local dentro del mismo directory da la versión correcta de 2.2.3.

Estoy ejecutando los commands en zsh con el siguiente .zshrc:

 export PATH="$HOME/.bin:$PATH" eval "$(rbenv init - --no-rehash zsh)" # recommended by brew doctor export PATH="/usr/local/bin:$PATH" export PATH="$HOME/.rbenv/bin:$PATH" eval "$(rbenv init -)" if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi 

Sólo quiero poder ejecutar la aplicación de Rails localmente y usaré algo distinto de rbenv para la administración de versiones de Ruby si es necesario.

  • ¿Cómo forzar la connection Thunderbolt-Ethernet al cambiar de networking sin reiniciar el orderador?
  • ¿Cómo escoge la Mac qué connection utilizar cuando se conectan Wifi y Ethernet?
  • Mi MacBook Pro pierde su connection a mi enrutador WiFi
  • ¿Para permitir que una Mac utilice automáticamente Wifi y Ethernet para duplicar la velocidad de connection?
  • ¿Funciona algún adaptador USB 3.0 a Gigabit Ethernet con OS X?
  • ¿Cómo puedo solucionar o restablecer un adaptador Thunderbolt Ethernet?
  • Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).