¿Puedo instalar y ejecutar Safari 8 en OS X 10.11 El Capitan?

Soy un desarrollador que admite Safari 8 y 9 y me gustaría poder ejecutar ambos en la misma máquina. Supongo que Safari 9 no se ejecutará en Yosemite. ¿Hay alguna manera de instalar Safari 8 en El Capitan?

  • De Yosemite a Mavericks
  • ¿Cómo mostrar siempre los controles de window en las aplicaciones de pantalla completa de Yosemite?
  • iMac no se reiniciará después de la actualización a Yosemite
  • ¿Cómo puedo identificar qué causa que mi Mac se cuelgue permanentemente al apagarlo?
  • Métodos abreviados de keyboard de "Buscar tabs" de Safari
  • ¿Es posible actualizar un Mac Pro (2007) con Lion (10.7) a Yosemite (10.10)?
  • Cómo restablecer el estado del usuario de networking al estado de "primera vez"
  • La resolución OS X Yosemite "salta" al iniciar session
  • 2 Solutions collect form web for “¿Puedo instalar y ejecutar Safari 8 en OS X 10.11 El Capitan?”

    También soy un desarrollador web con la necesidad de probar versiones anteriores de Safari. Esta es su mejor apuesta (advertencia: esto supone que posee VMware Fusion o un emulador de máquina virtual similar que puede manejar Mac OS).

    Asumiendo que ha actualizado su Mac a través de versiones anteriores de Mac OS (Yosemite, El Capitan, etc.), aún puede acceder a aquellos en la AppStore en "Comprado". Encuentre el SO que desee y click el button "Descargar".

    Una vez hecho, revisa tu carpeta / Aplicaciones para "Instalar El Capitán" (Olvidé el nombre exacto, pero comienza con "Instalar"). Con VMware Fusion, es terriblemente fácil instalar esto como una máquina virtual. Abra Fusion y agregue una nueva máquina, y elija "Instalar desde disco o image" y simplemente arrastre / suelte la aplicación de installation de Mac OS en la window de import de VMware.

    Siga los pasos usuales para instalar una máquina virtual, asegúrese de asignar suficiente RAM y ¡listo! Al hacer esto, pude instalar El Capitán como un sistema operativo virtual en mi máquina Sierra y probarlo en Safari 9.

    Si bien no puede instalar versiones anteriores de Safari, puede emular las versiones anteriores. Desde el menu Desarrollo, select Agente de usuario y luego Otro ….

    Desde allí, puede ingresar un agente de usuario personalizado. Por ejemplo, desde el enlace en la respuesta anterior de Tetsujin, puede replace el agente de Safari por lo tanto:

    Mozilla / 5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit / 600.7.12 (KHTML, como Gecko) Versión / 8.0.7 Safari / 600.7.12

    Debería poder emular cualquier versión anterior de Safari de esta manera.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).