No se puede instalar JDK 7 en macOS Sierra 10.12.6

Intenté instalar JDK 7u67 en mi MacBook Pro con macOS Sierra 10.12.6, pero lo único que obtengo es este post de error:

Java de Oracle requiere Mac OS X 10.7.3 o posterior.

Realmente no tiene sentido para mí, porque ya tengo una versión más alta, por lo que Java debería ser capaz de instalar. ¿Alguien ha enfrentado el mismo problema, por favor?

  • ¿Cómo especificar qué dictionarys se deben usar haciendo clic y presionar en el panel táctil?
  • Espacio perdido después de eliminar la partición de Boot Camp
  • iMac no puede comunicarse con la impresora
  • Recuperar file zip eliminado de macOS High Sierra
  • ¿Mostrar en Finder para Photos.app?
  • Mac dice que la contraseña es incorrecta, pero está bien. Tengo que ingresarlo dos veces para iniciar Mac todo el time. ¿Cómo podría resolverlo?
  • No se requiere contraseña de inicio de session después de dormir
  • Problema de SSD de MacBook Pro
  • 2 Solutions collect form web for “No se puede instalar JDK 7 en macOS Sierra 10.12.6”

    Esto es algo obvio que sucede, porque JDK 7 se creó para versiones anteriores de macOS. Necesita utilizar JDK 8 para instalarlo con éxito en su versión actual de macOS. Compruebe aquí: Java SE Development Kit 8 Descargas

    La comprobación se realiza mediante la function pm_install_check() en la distribución del package.

    1. Copie el package de la image del disco para que pueda ser editado
    2. Ábralo con el browser de files
    3. Edite el file de distribución con TextEdit (haga clic derecho en Distribución y elija Abrir con para editar el file en su lugar).
    4. Elimine las siguientes líneas para que la function siempre devuelva verdadero.

    5. Guarde el file y abra el package.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).