No se puede download Mavericks a través de App Store ni actualizar desde OS X 10.8.5 – No se admiten las instalaciones de Command Line

App Store menciona el siguiente post cuando bash download / instalar OS X Mavericks (10.9):

"Command line installs of OS X are not supported on systems older than 10.9." 

¿Entonces dice que necesito 10.9 para actualizar a 10.9?

  • ¿Cómo reclamar la partición de espacio libre en macOS High Sierra?
  • Antiguo MS Outlook Express para Mac copyr / exportar / mover
  • Viejo Mac OS X, no puede get acceso de administrador, modo de inicio seguro o de usuario único, ni reinstalar
  • Tratar de dejar caer la image de disco de Mac OS 9 sobre sheepshaver en Sierra me da un error "Coloque un file llamado 'Mac OS ROM' ..."
  • El keyboard BK3001BA no se conecta después de ingresar el código de acceso correcto
  • ¿Cómo puedo solicitar una input y luego pasar la variable en la terminal?
    • Mac mini (finales de 2012)
    • OS X 10.8.5 (12F45)
    • iTunes 11.1.2 o superior (hasta ahora)
    • usando App Store 1.2.2 (129.16)

    P: ¿Cómo puedo download el instalador OS X Mavericks 10.9?

    (Nota: estoy ejecutando el Mac mini sobre VNC ("Uso compartido de pantalla") sin monitor).


    Actualización 1

    1. Descargué el instalador de Mavericks usando la computadora portátil de un amigo.
    2. Visitar Apple Store parece ser la ruta de soporte pnetworkingeterminada para este error: "puedes visitar cualquier tienda Apple Store para get ayuda con la descarga" ( http://www.apple.com/osx/how-to-upgrade/ )

    Actualización 2

    CVCGDisplayLink :: setCurrentDisplay no encontró una visualización válida


    Actualización 3

    Después de pensar que tal vez tenga un set de variables de entorno, encontré la siguiente publicación y, por supuesto, mi file /etc/launchd.conf tenía la siguiente línea:

    setenv COMMAND_LINE_INSTALL 1

    que eliminé / comenté con un # al frente.

    #setenv COMMAND_LINE_INSTALL 1

    ¡Ahora estoy ejecutando Mavericks 10.9.1! 🙂 – la actualización fue maravillosamente .

    Había agregado esa línea hace varios meses para instalar algo, y lo había olvidado. (Espero que esta solución ayude a alguien)

    Lección aprendida:

    • Realice un seguimiento de los cambios de configuration temporales (o restaure el original cuando haya terminado)

  • Procesos pnetworkingeterminados?
  • Actualización centralizada para aplicaciones de terceros
  • ¿Cómo deshabilitar la búsqueda de palabras con un toque de tres dedos?
  • ¿Cómo cambiar el icono de Dock cuando alguna aplicación ha creado imágenes genéricas de icons?
  • ¿La combinación de teclas no funciona cuando se usa la barra táctil?
  • ¿Hay un logging de actividad detallado en Mac OS X que enumera mis commands y acciones recientes?
  • 3 Solutions collect form web for “No se puede download Mavericks a través de App Store ni actualizar desde OS X 10.8.5 – No se admiten las instalaciones de Command Line”

    Esta no es la ruta ideal, pero siempre puede arrancar en la Recuperación HD y volver a instalar el sistema operativo en una unidad USB externa. Su Mac podría volver a download Mavericks directamente, pero lo más probable es que vuelva a download la versión que creó Recovery HD.

    En ese punto, dejaría intacta su unidad interna e instalaría un sistema limpio en la unidad externa.

    A partir de ahí, podrá arrancar desde esa unidad externa que no tenga el nuevo iTunes y download Mavericks. Una vez que tengas el instalador, puedes ejecutarlo contra la unidad interna o la unidad externa y migrar datos si primero eliges actualizar la versión externa a Mavericks.

    El file /etc/launchd.conf tenía el siguiente set de variables de entorno:

    setenv COMMAND_LINE_INSTALL 1

    que eliminé / comenté con un # al frente.

    (La línea se agregó meses antes para instalar una aplicación pero no se eliminó).

    Nota: Esta publicación también me ayudó a encontrar / recordar dónde están almacenadas las variables de entorno: https://stackoverflow.com/a/588442/2533809

    La actualización fue muy sencilla, ahora estoy ejecutando Mavericks 10.9.

    en caso de que esto todavía sea un problema

    https://discussions.apple.com/message/23816172#23816172

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).