Migración del antiguo proyecto de Xcode a la versión 4.3

Hoy pasé a la última versión de Xcode (4.3). Intenté abrir un proyecto antiguo y cuando bash iniciar el simulador iOS, me devuelve el siguiente error:

Xcode cannot run using the selected device. No provisioned iOS devices are available with a compatible iOS version. Connect an iOS device with a recent enough version of iOS to run your application or choose an iOS simulator as the destination. 

También traté de crear un nuevo proyecto y allí puedo lanzar el simulador.

¿Cómo puedo solucionar este problema y ejecutar todos mis viejos proyectos de nuevo?

¡Gracias!

  • Problemas con la descarga de Xcode 7.3
  • Reinstalando XCode
  • Ejecutando Xcode 6 en iMac 2009
  • ERROR ITMS-90158: los esquemas de URL deben comenzar con un carácter alfabético: ID de cliente de Google
  • No se puede habilitar el desarrollo en iOS 10.1.1
  • ¿Hay alguna manera de exportar la configuration de color de syntax de una installation de Xcode a una nueva?
  • Eliminar aplicación del simulador de iPhone 5.1
  • ¿Cómo obtengo Xcode 4 para NO borrar el logging entre ejecuciones?
  • 2 Solutions collect form web for “Migración del antiguo proyecto de Xcode a la versión 4.3”

    El problema es que Xcode 4.3 ignora el esquema que había seleccionado en versiones anteriores y lo configura automáticamente para que se ejecute en el dispositivo para proyectos de iOS. Como no tiene un dispositivo elegible conectado a su computadora, obtiene este error. La solución es simple. En la barra de herramientas, click el menu que dice iOS Device y elija una de las opciones del simulador.

    enter image description here

    Verifique que el SDK para la versión de iOS seleccionada en el proyecto antiguo todavía esté en su máquina. Por ejemplo, si compiló la aplicación contra 4.0 y luego eliminó ese SDK (la actualización de Xcode puede haberlo hecho), esperaría que Xcode presentara dicho post.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).