Instalar Python en Mac 10.5.8 de 64 bits

Estoy trabajando para instalar Python en mi Mac 10.5.8 y he tenido muchos problemas.

Las descargas estándar en Python.org no muestran una versión compatible.

  • La installation de Ghostscript usando MacPorts falla
  • ¿Qué herramienta es mejor para eliminar páginas de un PDF?
  • Manualmente mueva iCal al León
  • Instale Sierra como sistema operativo invitado en VM con Parallels 12
  • Eliminar y reinstalar Python en Mac: ¿puedo confiar en estas references antiguas?
  • ¿Algún efecto secundario al compartir un disco de copy de security de Time Machine entre Lion y Snow Leopard?
    • Tienen 10.3 – 10.6 para 32 bits
    • Tienen 10.6 – 10.7 para 64 bit

    Traté de download e instalar la versión de 32 bits para 10.5, sin embargo, al iniciar el IDLE, se cierra "Inesperadamente".

    Me han dicho que Python viene preinstalado en computadoras Mac OSX, pero cuando ejecuto "python" en el terminal recibo este error:

    william-johnsons-macbook:~ Will$ python dyld: unknown requinetworking load command 0x80000022 Trace/BPT trap william-johnsons-macbook:~ Will$ 

    Si alguien tiene algún consejo u otras references que no estén en el sitio python.org, realmente lo agradecería.

  • ¿Cómo restauro mis notas en macOS Sierra?
  • Establecer contactos y calendar de Outlook.com en OSX
  • ¿Por qué mi MacBook Pro de mediados de 2010 experimenta una pantalla azul en blanco y se bloquea?
  • Iniciado en Windows, ¿cómo habilito el acceso a un volumen Mac CoreStorage?
  • iTerm2, Unicode y Sympy
  • OSX 10.7 File Sharing no respeta Group: Everyone "Sin acceso". Compartir muestra públicamente
  • 2 Solutions collect form web for “Instalar Python en Mac 10.5.8 de 64 bits”

    Ha pasado mucho time desde que tuve que hacer esto para 10.5.8, pero seguí estas instrucciones: http://web.archive.org/web/20090508090926/http://blog.captnswing.net/2009/04/ 19 / python-mod_wsgi-64bit-mac-os-x-105 / (tenga en count que el website original se ha ido, de ahí el enlace de WayBack)

    Aquí hay una publicación que hice sobre el tema cuando estaba intentando: http://buffalothedestroyer.blogspot.com/2009/04/python-64-bit.html

    Pero, ¿necesitas Python de 64 bits en 10.5.8? Francamente, no creo que valga la pena, pagaría unos dólares y uploadía a 10.6 o 10.7.

    Si solo es un problema con Python de 32 bits, ¿qué python estás usando? (es decir, ¿ which python devuelve which python ?)

    ¿Qué pasa con Python de MacPorts? es lo mismo que desde Python.org, pero para su architecture y puede administrar libs más fácilmente.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).