Instalar Python 3.0 en mi Mac

Estoy usando Python 2.6.1 incorporado, sin embargo, necesito ejecutar Python 3.0 de vez en cuando.

  • ¿Está bien instalar Python 3.0 en mi Mac? ¿Hay algo que deba ser precavido?
  • ¿Qué tal el easy_install? Si tengo 2.6 y 3.0 en mi Mac, ¿dónde está instalada la biblioteca para easy_install?
  • ¿Hay alguna manera fácil de hacer que Python apunte a 2.6 o 3.0?

  • La aplicación basada en Python requiere pasar por alto la advertencia de 'desarrollador desconocido'
  • no puede confirmar la configuration de networking a través de la línea de command
  • Vinculación de Python como herramienta de compilation externa en Xcode 7 El Capitan
  • "No se puede ejecutar el file binary" con un alias de binary
  • La Protección de Integridad del Sistema interrumpe DYLD_LIBRARY_PATH para scripts de Python
  • ¿Python está preinstalado en todas las versiones de Mac?
  • Python Virtualenv está roto desde la actualización a OS X Mountain Lion
  • En Sierra: ¿Cómo instalar Qt 5.8.0 / PyQt 5.7.1 / sip 4.19 / Python3.5 para instalar y trabajar correctamente?
  • One Solution collect form web for “Instalar Python 3.0 en mi Mac”

    Hay varias forms de instalar Python y de qué manera afecta las respuestas posteriores. En todos los casos, debe instalar una versión posterior de Python 3: 3.1.3 es la versión más reciente. Para elegir cuál ejecutar, llamaría a python3.1 o python2.6 para que sean explícitos, ya que el idioma es lo suficientemente diferente como para que el código sea específico de las twigs 2.x o 3.x. De hecho, gran parte del código comienza con la línea #! / Usr / bin / env python, pero es 2.x específico. Diría que tener el ejecutable de python en su path vinculado a python3.1 sería un problema. Los scripts de Apple que usan python siempre buscan / usr / bin / python, por lo que siempre encontrarán la versión de Apple y no una versión de otra versión instalada correctamente.

    easy_install es de un package externo setuptools y puedes decirle a setup.py dónde ponerlo.

    Lo más simple es instalar desde el instalador de python.org Esto le dará un ejecutable de python3 en / usr / local / bin (y posiblemente python también). En este caso, crearía un enlace simbólico de python en ~ / bin (apuntando a apple python o python3 y puede cambiar a donde apunta como lo requiera sin sudo, lo que requeriría un enlace en / usr / local / bin.
    En este caso, creo que easy_install para python3 terminará de forma pnetworkingeterminada en / usr / local / bin y el de Apple estará en / usr / bin

    Utilizo versiones de macports y se instalan en / opt / local y tienen un script de selección de puerto que cambiará / opt / local / bin / python entre las versiones 3.1 o 2.6 (o cualquier otra que haya instalado) – desafortunadamente no no hace esto para easy_install que se encuentra en /opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin (o 3.1, etc.)

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).