directory de packages de sitios de python

Tengo por alguna razón dos ubicaciones para packages de sitios de Python.

Python en sí está aquí:

  • Retina pantalla compatible con Python IDLE?
  • ¿Cuál es la forma correcta de instalar Python en OS X?
  • Homebrew: SHA1 no coincide incluso después de la actualización
  • Se instaló python2.7 adicional en Snow Leopard. ¿Qué sucede con los modules que deseo instalar?
  • ¿La installation de Wireshark a través de homebrew proporciona una interfaz gráfica?
  • Registros de installation de "brew formula"
  • > $ which python > /Library/Frameworks/Python.framework/Versions/2.7/bin/python 

    Mi variable de ruta es:

     $ echo $PATH /Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/git/bin:/opt/opengeo/pgsql/9.1/bin 

    xlrd está instalado aquí y se puede acceder desde python

     > $ pip install xlrd > Requirement already satisfied (use --upgrade to upgrade): xlrd in /Library/Python/2.7/site-packages $ python Python 2.7.3 (v2.7.3:70274d53c1dd, Apr 9 2012, 20:52:43) [GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin Type "help", "copyright", "cnetworkingits" or "license" for more information. >>> import xlrd >>> 

    numpy está instalado aquí y no se puede acceder desde python

     > $ pip install numpy > Requirement already satisfied (use --upgrade to upgrade): numpy in /usr/local/lib/python2.7/site-packages $ python Python 2.7.3 (v2.7.3:70274d53c1dd, Apr 9 2012, 20:52:43) [GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin Type "help", "copyright", "cnetworkingits" or "license" for more information. >>> import numpy Traceback (most recent call last): File "<stdin>", line 1, in <module> ImportError: No module named numpy 

    ¿Qué tengo que hacer para get numpy también trabajando con Python. Estoy buscando la 'solución más limpia'.

  • ¿Puedo instalar o actualizar las aplicaciones de Mac App Store a través de una línea de command usando terminal?
  • ¿Cómo instalar herramientas de desarrollador de command-line en Yosemite?
  • ¿Cómo puedo get la ID de Apple asociada de un usuario desde la línea de command?
  • Automatizando terminales al inicio
  • ¿Cómo configurar el time de espera para el command 'ping'?
  • Nueva terminal en el mismo directory
  • One Solution collect form web for “directory de packages de sitios de python”

    Como solución a corto ploop, debería poder ejecutar

     cp /usr/local/lib/python2.7/site-packages/numpy* /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/ 

    ya que las versiones de python son las mismas, y /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages es (entre otros lugares) donde su binary de python searchá modules.

    Me preocupa que /usr/bin/python no exista, ya que es lo que se envía con OSX y se requiere para que se ejecute algo del sistema / sistema operativo. La razón por la que tienes tantos directorys de site-packages (en realidad tienes más de lo que enumeró en tu pregunta) es que parece que has instalado una versión de python.org (la /Library/Frameworks/... una) y quizás una versión de terceros de Homebrew u otro administrador de packages (MacPorts se instala de forma pnetworkingeterminada en el directory /opt/local ). Tu versión de pip también se instaló desde esa fuente, así que si quieres usar la versión de python.org como tu pnetworkingeterminada, entonces necesitarás instalar pip nuevamente (asegúrate de usar la versión de setuptools , ya que la distribute está extinta). Una vez hecho esto, puedes ejecutar pip install numpy --upgrade para asegurarte de que tienes la versión más reciente, que es la 1.7.1 actualmente.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).