¿Desea actualizar al último libssl de Mountain Lion sin MacPorts?

Intenté instalar postgresql, utilicé el package de installation de EnterpriseDB 9.1.5, ahora psql no funciona. Parece ser un problema de ruta, pero ahora, está la cuestión de libssl. Parece que hay una nueva versión, pero ¿cómo se puede actualizar sin MacPorts? Gracias

$ psql dyld: Library not loaded: @loader_path/../lib/libssl.dylib Referenced from: /usr/lib/libpq.5.dylib Reason: Incompatible library version: libpq.5.dylib requires version 1.0.0 or later, but libssl.0.9.8.dylib provides version 0.9.8 Trace/BPT trap: 5 

  • /Library/Server/Wiki/Database.xpg consumiendo una gran cantidad (313GB!) De espacio en disco
  • Administrador de dispositivos y post de error Postgresql
  • PostgreSQL no está en la ruta después de la installation
  • Usar postgres con launchd sin problemas constantes
  • ¿Cómo reiniciar PostgreSQL instalado por Brew en OSX?
  • cómo instalar postgres 9.6 y un PostGIS correspondiente
  • /System/Library/LaunchDaemons/com.apple.servermgrd.plist falta - Causa postgres para que no se inicie correctamente
  • postresql no se instala con homebrew en El Capitain 10.11.5
  • 2 Solutions collect form web for “¿Desea actualizar al último libssl de Mountain Lion sin MacPorts?”

    Así es como lo arreglé, está basado en un par de hilos en Stack Overflow.

     sudo cp /Library/PostgreSQL/9.1/lib/libssl.1.0.0.dylib /usr/lib sudo cp /Library/PostgreSQL/9.1/lib/libcrypto.1.0.0.dylib /usr/lib sudo ln -fs /usr/lib/libssl.1.0.0.dylib /usr/lib/libssl.dylib sudo ln -fs /usr/lib/libcrypto.1.0.0.dylib /usr/lib/libcrypto.dylib 

    Tome nota de cómo se veían los enlaces que está reemplazando antes de sobrescribirlos para poder volver a colocarlos como estaban si le causa dolor. No estoy convencido de que esta sea una buena idea todavía, pero está funcionando hasta el momento. Voy a editar si vuelve a morderme en el culo.

    Resulta que estaba teniendo un problema con homebrew, principalmente pkg-config. Parece que a homebrew realmente no le gusta no instalarse en / usr / local bajo Mountain Lion. De cualquier forma, salga de ~ / y entre / usr / local, volviendo a elaborar todo (ya que la mayoría de las cosas se instalaron con prereq pkg-config). Se eliminó manualmente la versión EnterpriseDB de postgres, y un par se reinicia más tarde, se ejecutó un buen postgres, psql y libssl. Si encuentro más errores, puedo darle una oportunidad a su solución.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).