¿Cuál es la política de Apple para admitir actualizaciones de security en versiones anteriores de OS X?

¿Apple tiene una política con respecto a cuánto time continuarán lanzando y soportando correcciones de security para cada lanzamiento de OS X? He buscado en Internet y he encontrado algunas publicaciones en el foro que dicen "solo para las versiones actuales y las versiones anteriores más recientes", pero ninguna parece tener una reference oficial. Además, confunden el problema algunas publicaciones relativamente recientes que afirman que todavía reciben actualizaciones de security para versiones tan antiguas como 10.2.

Mi preocupación aquí es principalmente desde el punto de vista de la security. El Instituto Nacional de Estándares y Tecnología del Departamento de Comercio de los Estados Unidos de América declara en este documento: NIST SP 800-53 , control SI-02 (Remediación de defectos) que existen requisitos que (entre otras cosas) "La organización … identifica, informa y corrige los fallos del sistema de información " . Para los sistemas que ejecutan sistemas operativos que están más allá de su ciclo de vida de soporte, no se puede esperar confiablemente que corrijamos las vulnerabilidades descubiertas porque el proveedor ya no proporcionará parches. Por lo tanto, conocer el ciclo de vida de soporte esperado de un producto (y, especialmente, si ya ha expirado) es fundamental para continuar manteniendo el cumplimiento de este control.

  • Cómo configurar OS X para exposiciones
  • ¿Cómo instalar Safari 10 en OS X El Capitan?
  • ¿Puede el cliente de Microsoft RDC utilizar la resolución de escala retina en la MacBook Pro?
  • ¿Puede ejecutar `yes> / dev / null` dañar una Mac?
  • ¿Cómo hacer una ISO reproducible de DVD desde una carpeta VIDEO_TS?
  • ¿Por qué no puedo resolver los nombres de las máquinas en mi LAN a su dirección IP?
  • ¿Proporciona Apple esta información en línea en línea para el público en general? ¿Qué versiones son compatibles actualmente (la versión actual es Lion) y cuánto time (suponiendo que no haya cambios en la política) seguirán siendo compatibles?

  • La acción de carpeta actúa sobre files no especificados en el flujo de trabajo
  • ¿Necesita ayuda para descubrir por qué un file (test_find.pyc) se abre al inicio?
  • ¿Puedo tener suavizado de fuente en una pantalla externa, pero no en la propia pantalla retina del MacBook Pro?
  • Usar micrófono externo en Bootcamp
  • ¿Por qué OS X Mail no reconoce que una dirección de correo electrónico pertenece a un contacto existente?
  • ¿Reemplazar el icono de carpeta azul con una image personalizada?
  • 5 Solutions collect form web for “¿Cuál es la política de Apple para admitir actualizaciones de security en versiones anteriores de OS X?”

    Estoy seguro de que Apple tiene una política, pero claramente no se ha lanzado al público y probablemente se vuelva a evaluar constantemente en function de muchos factores.

    Cada vez que necesito saber qué se admite ahora, voy al índice de lo que cubre Apple Care (ya que AppleCare es la twig de soporte que mantiene artículos de la base de conocimiento, responde preguntas, etc.)

    • El map de soporte de Apple : esto responde a su pregunta sobre la list definitiva de sistema operativo con soporte activo. A partir de mayo de 2012, esto incluye tres versiones principales. 10.5, 10.6, 10.7 A partir de septiembre de 2012 (después de que Mountain Lion haya estado fuera durante más de un mes), el soporte para 10.5 aún no se ha eliminado del Sitemap de soporte, por lo que estamos en una window donde cuatro versiones principales del sistema operativo todavía compatible.

    Por supuesto, puede ver las últimas actualizaciones de todos los sistemas operativos OSX en sus respectivas páginas de soporte, incluso más allá del momento en que están "activamente respaldadas".

    • Lion Support
    • Soporte de Snow Leopard
    • Leopard Support
    • Soporte de Tiger
    • Soporte Panther
    • Jaguar y soporte anterior, que presumiblemente cubre a Puma y Cheetah pero no a Kodiak .

    No creo que Apple publique una política dura y rápida. Mi experiencia es que las dos versiones actuales y anteriores siempre han sido compatibles. Hay momentos en los que se admiten más de tres versiones, por lo que es posible que vea esto cuando se publique 10.8. También podría estar más vinculado al hardware que se vendió. En general, Apple basa el soporte en las dates de venta en los EE. UU. Con una window de 5 años para soporte de hardware luego de que un model se descontinúa para su venta. También esperaría que los grandes pedidos institucionales (educación, gobierno) tiendan a mantener el hardware y el software más antiguos en apoyo debido a acuerdos contractuales o leyes locales (ejemplos de eso son cualquier cosa que se venda en California o Turquía, contratos gubernamentales en Virginia y aún diferentes regulaciones en Francia.)

    Si tiene una relación comercial con Apple debido a que count con la certificación de técnico o count con soporte de nivel de table de ayuda , recibirá avisos previos de qué productos y software se anuncian como no compatibles antes de que llegue el momento.

    Básicamente, si necesita conocer este tipo de información no pública con anticipación, puede get la certificación (más económica, requiere más time y conocimiento) o pagar por este nivel de asistencia y tener acceso a la información que espera para que pueda planificar para el cambio y sé que eres apoyado por Apple. Como puede ver, hay varios factores que parecen afectar la duración de la window de soporte y hay varias opciones gratuitas para ayudarlo a adivinar el momento si no necesita pagar esta información.

    No he visto ninguna política oficial de Apple para OS X, pero hay una input de KB para hardware: productos antiguos y obsoletos (la mayoría de estos son PPC, pero los de Intel están empezando a aparecer). En cuanto a lo que sucede en realidad, como ya has descubierto, es solo la versión actual y la anterior. Puede verificarlo yendo a Mac OS y a la sección de Descargas de software del sitio de Soporte de Apple (alternativamente Descargas , luego eligiendo Mac OS y Software y luego Mac OS), eligiendo Leopard (o buscando una versión anterior) y comparando la date de la última Actualización de security con el lanzamiento de la versión de esa +0.2 (Lion en ese ejemplo). Por supuesto, debido a la falta de una política establecida, no hay ninguna garantía de que esto continúe.

    Ayer mismo vi esto: "Apple protege OS X 10.5 Leopard de Flashback Malware"

    No han (todavía) hecho Tiger, supongo.

    Parece que el software stackexchange no considera que eweek sea ​​una "fuente confiable", así que agrego este Apple Link

    el soporte dura aproximadamente 40 meses.

    OSX 10.9 ya no recibe actualizaciones de security: support.apple.com/en-us/HT201222

    Vida útil de soporte de OSX

    http://www.computerworld.com/article/2950580/operating-systems/the-end-is-near-for-os-x-mountain-lion-support.html

    Recuerde que Apple se ve a sí misma como una empresa de hardware. No venden sistemas operativos, venden Macs. No se preocupan por las actualizaciones de security para ningún SO específico; más bien, se centran en actualizaciones de security para todos los Mac actualmente compatibles.

    Primero, definamos el soporte actual. Apple admite todas las Mac que aún no son antiguas u obsoletas . En términos prácticos, eso cubre todas las Mac actuales (por supuesto), así como todas las Mac descontinuadas hace less de siete años.

    Considere los models de iMac lanzados en octubre de 2009. Fueron descontinuados en julio de 2010, entonces (según la definición de Apple) todavía no están obsoletos. Se enviaron con Mac OS X 10.6.1 Snow Leopard. Y si bien es cierto que Apple ya no ofrece actualizaciones para Snow Leopard, también es cierto que esos iMacs de finales de 2009 se pueden actualizar a Sierra.

    Entonces (desde la perspectiva de Apple), aquellos que ofrecen actualizaciones de security actuales. Si tiene un iMac a fines de 2009, actualice a macOS 10.12 Sierra y estará seguro.

    Todo esto es inferencia de mi parte; No creo que Apple haya establecido alguna vez una política oficial con respecto a las actualizaciones de security. Pero mis inferencias son (por lo que puedo decir) coherentes con los hechos.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).