coreaudiod y launchd toman 80% y 40% de procesador respectivamente

Acabo de actualizar de Mavericks a Yosemite, la descarga fue lenta pero finalmente funcionó, así que no creo que ninguno de los files estuviera dañado. No había ningún problema con la installation, por lo que sé tampoco. Todo lo que sé es que cuando me desperté después de dejar mi MacBook Pro (15 pulgadas, mediados de 2010) su ventilador estaba girando fuera de control en la pantalla de inicio de session.

Cuando reinicié y miré el monitor de actividad, vi que el audio central y el launchd eran los culpables. He intentado lo siguiente para solucionar mi problema:

  • Despejando la PRAM.
  • Despejando el SMC.
  • Eliminando el plist para el panel de preferences de audio.
  • Verificando los permissions del disco.
  • Reparar permissions de disco.

Información adicional: He ejecutado etreCheck algunas veces y he arreglado la mayoría de las cosas que señaló, todo lo que queda es:

Los demonios de lanzamiento del sistema con problemas: [fail] com.apple.systemstatsd.plist

Lanzar daemons con problemas: [invalid?] Com.adobe.SwitchBoard.plist Aide

He buscado y todavía no he encontrado respuestas que funcionen. ¿Algo más que pueda hacer aparte de una reinstallation?

También me he dado count de que el bluetooth ya no se puede apagar, aunque en realidad no parece estar encendido, también se apreciarán las correcciones para eso.

  • ¿Yosemite Upgrade Destruye Bootcamp?
  • El file de hosts se restablece después de cada reinicio
  • Cambió el nombre de usuario, rompió todo
  • ¿Cómo encuentro el número de versión de las bibliotecas del sistema en diferentes versiones de OS X?
  • Problema con el buscador: la unidad USB se abre en una window separada para cada carpeta
  • Apple Screen Sharing = VNC / RDP?
  • ¿Dónde está "Hoy" y "Ayer" en el menu del Finder?
  • Yosemite 10.10.3 solicita la contraseña de google todas las semanas con la authentication de 2 factores
  • One Solution collect form web for “coreaudiod y launchd toman 80% y 40% de procesador respectivamente”

    Acabo de tener exactamente el mismo problema después de reiniciar. Anteriormente había descargado un montón de services.

    El problema del bluetooth se debía a la descarga del service bluetooth, pero tenía un mouse bluetooth conectado a través de USB, supongo que hubo alguna anulación en el IO o algo así.

    Cargar el service nuevamente solucionó el problema.

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.blued.plist

    El problema principal de audio parece haberse solucionado al volver a cargar el asistente de video

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.cmio.IIDCVideoAssistant.plist

    Espero que esto ayude a alguien, ya que no debería haber una restauración completa del sistema debido a uno o dos problemas de service.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).