Comstackndo CUPS 2.0 en 10.9: ¿qué archflags usar?

Instalé CUPS 2.0.0 (cups.org) pero evidentemente necesitaba include indicadores de architecture específicos. Ahora se han roto varias cosas en mi mac (por ejemplo, Word no se iniciará). Los posts de error revelan que el problema es con libcups.2.dylib ("construido con la architecture incorrecta").

Por consejo que encontré para una versión anterior de OSX, intenté reconfigurar CUPS usando:

  • Descomprimiendo un file, el icono de la carpeta aparece debajo del file
  • ¿Problemas de performance, posiblemente malware?
  • ¿Restaurar desde CCC o Time Machine?
  • Directorio de trabajo incorrecto, si el script bash se abre haciendo doble clic
  • Mac, arrastrando elementos a las carpetas del escritorio sigue abriendo una window de búsqueda de inmediato
  • Cómo crear y transferir files ZIP seguros (encriptados) de Mac a PC
  • configure –with-archflags = "- arch i386 -arch x86_64" –with-ldarchflags = "- arch x86_64"

    pero eso no solucionó el problema. ¿Cuál es el archflag correcto para build CUPS en 10.9?

    No estoy seguro de si esto está relacionado, pero ahora no puedo hacer que Finder muestre files invisibles, lo que me impide volver a la configuration anterior a CUPS 2.0 con Time Machine.

  • ¿Apple ha anunciado si la actualización de bash de "Shellshock" se aplicará automáticamente a través del mecanismo de parcheo de la App Store?
  • Recomendación de software: analizador de networking de command-line que muestra el process de propiedad
  • Abra la aplicación específica del bucle de enlace de Internet
  • Cambiar la pestaña pnetworkingeterminada en el cuadro de dialog emergente Caracteres
  • ¿Cómo obtengo command + tab para detener el reorderamiento de espacios?
  • Se eliminó la carpeta Películas, ahora quiero que vuelva
  • One Solution collect form web for “Comstackndo CUPS 2.0 en 10.9: ¿qué archflags usar?”

    No tengo 10.9 y CUPS 2.0, pero tuve una experiencia similar con 10.8.5 e bash poner en funcionamiento CUPS 1.7.2. La configuration pnetworkingeterminada hace que SÓLO construya un set de bibliotecas de 64 bits. Tuve éxito con el uso de los mismos indicadores de architecture para los parameters efectivos de CFLAGS y LDFLAGS:

    ./configure –with-archflags = '- arch i386 -arch x86_64' –with-ldarchflags = '- arch i386 -arch x86_64' make clean make

    Antes de solucionar esto, muchos progtwigs (desde Spotlight a Safari a Outlook) no funcionaban con librerías de 64 bits * .dylib.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).