¿Cómo depurar trampa Trace / BPT: 5?

Me sale un Trace/BPT trap: 5 error al usar el command open:

 $ open -a Emacs Trace/BPT trap: 5 $ open -a Safari Trace/BPT trap: 5 $ open -a TextEdit Trace/BPT trap: 5 

¿Alguna sugerencia de cómo puedo networkingucir lo que está causando esto?

  • ¿Hay una mejor manera de search en los menus?
  • Eliminar desplazamiento horizontal en el buscador con vista en miniatura grande
  • ¿Cómo aceptar la licencia de Xcode?
  • cómo get scripts de shell para ejecutarse en el inicio de Yosemite
  • Los gestos de retroceso / avance de cromo ya no funcionan después de la actualización de Mavericks
  • Monte la unidad compartida a través de AFP en el terminal
  • Entiendo de mi pregunta anterior, que tiene que ver con no encontrar una biblioteca dinámica, pero ¿cuál es y por qué no encuentra la biblioteca?

    Frente a la GUI, todo funciona bien, pero está presente desde termnal, así como iTerm.

    Sistema: Macbook Pro Retina, Maverick

    ¿Alguna sugerencia?

    INFORMACIÓN ADICIONAL:

     $ otool -L /Applications/TextEdit.app/Contents/MacOS/TextEdit /Applications/TextEdit.app/Contents/MacOS/TextEdit: /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 20.0.0) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 1056.0.0) /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 228.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 59.0.0) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 855.11.0) /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1251.0.0) /System/Library/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics (compatibility version 64.0.0, current version 600.0.0) 

    y

     $ otool -L /Applications/Emacs.app/Contents/MacOS/Emacs-10.7 /Applications/Emacs.app/Contents/MacOS/Emacs-10.7: /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1138.47.0) /usr/lib/libxml2.2.dylib (compatibility version 10.0.0, current version 10.3.0) /usr/lib/libncurses.5.4.dylib (compatibility version 5.4.0, current version 5.4.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11) /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 227.0.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 53.0.0) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 635.21.0) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 41.0.0) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 833.25.0) 

    así que no puedo ver nada que falta?

  • ¿Hay una manera de hacer la fuente del terminal less borrosa?
  • Tecla de acceso directo a la aplicación de menubar en Mavericks
  • La pantalla externa adquiere aleatoriamente y pierde señal bajo Mavericks 10.9.4
  • Instalar Mavericks en MacBook no compatible 4,1
  • Deshabilitar el antialiasing inducido por desplazamiento en la vista preliminar y en otras aplicaciones de PDF
  • ¿Cómo deshabilitar el dialog "cambiar un evento repetitivo" en el calendar de Mac?
  • 3 Solutions collect form web for “¿Cómo depurar trampa Trace / BPT: 5?”

    Sospecho que ahora habrá visto reaparecer el problema. La solución que describió tuvo un efecto secundario que terminó por un time resolviendo el problema.

    Creo que el problema tenía que ver con el context de security en el que el shell de su terminal intentaba iniciar progtwigs que intentaban conectarse al sistema de windows.

    Mi solución a este problema, siempre que ha ocurrido desde mis shells de Terminal.app, ha sido usar reattach-to-user-namespace ( https://github.com/ChrisJohnsen/tmux-MacOSX-pasteboard ). Por ejemplo, en un prompt de bash:

     tk-mbp:~ tommy$ wstorm Projects/my-webapp Trace/BPT trap: 5 tk-mbp:~ tommy$ exec reattach-to-user-namespace -l bash (reading ~/.bash_profile) tk-mbp:~ tommy$ wstorm Projects/my-webapp tk-mbp:~ tommy$ # that worked... 

    Cuando se reinició como parte de la corrección informada, tuvo el efecto secundario de crear un process de shell cuya connection con el context de security de su session de inicio de session con windows no era obsoleta, como lo había sido antes cuando los commands fallaban con "Trace / Trampa BPT: 5 ". Así que aunque podría haber habido un problema real con la configuration de PATH, creo que fue la actualización del entorno de process de la shell la que fue la verdadera solución.

    FWIW, Tengo reattach-to-user-namespace instalado a través de Homebrew.

    Parece que la variable PATH estaba causando el problema.

    Utilizando iTerm, la variable PATH incluía caracteres Unicode impnetworkingecibles. Lo /etc/paths.d hasta una input que agregué al directory /etc/paths.d (la ruta $HOME/bin ). Contenía después de la trayectoria un avance de línea. Al editar el fikle con nano, no logré borrar este carácter Unicode (?), Es decir, reiniciar no solucionó el problema, pero usé Emacs y borré todos los caracteres después de la ruta (dos caracteres mostrados como espacios que no eran visibles usando nano) y agregó un RETORNO.

    Reiniciado y estaba funcionando – y todavía lo es.

    Espero que siga así.

    Gracias por tu aportación.

    Yo tuve el mismo problema.

    Tenía un file oculto en /etc/paths.d/ que estaba confundiendo mi variable PATH. He eliminado el file y todo funciona normalmente.

    FYI el file era un file de deshacer generar por vim:. .<original filename>.un~

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).