AppleScript para habilitar VPN roto después de la actualización a 10.9.3

He estado usando un AppleScript para conectarme a la VPN de mi oficina. Después de actualizar mi macbook a 10.9.3, falla al ejecutar y arroja una exception

Unable to get network preferences

(Honestamente, es una traducción flexible, si alguien sabe cómo hacer que el editor de AppleScript muestre errores en inglés, me alegraría).

Código integer:

 tell application "System Events" tell current location of network preferences set VPNservice to service "VPN (L2TP)" -- name of the VPN service if exists VPNservice then connect VPNservice repeat until (connected of current configuration of VPNservice) delay 1 end repeat do shell script "route add 192.168.11.0/24 10.64.64.64" with administrator privileges end tell end tell 

¿Alguien sabe qué pudo haber causado el problema?

Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).