Aplicaciones / Xcode vs Desarrollador / Aplicaciones / Xcode

Tengo OSX 10.8 con Xcode 4.6.3 instalado (se muestra en la tienda de aplicaciones). Cuando selecciono Spotlight-search "xcode" veo dos resultados: Xcode – Mac & Xcode – Developer .

El primero se inicia como se esperaba, pero en el segundo recibo la siguiente advertencia: "Esta installation de Xcode 4.2 requiere Mac OS X 10.7 Lion. Instale una versión de Xcode Tools que admita Mac OS X 10.8". y se cierra al instante. Lo mismo si bash iniciarlo a través del buscador en Developer/Applications/Xcode .

  • Cómo encontrar un número de teléfono anotado en los contactos buscando una subcadena en el iPhone
  • Mac mini 2012 (núcleo cuádruple 2.3) Vs finales de 2014 (núcleo dual 2.8)
  • Desarrollo de iOS: por defecto GameCenter y In-App activado
  • ¿Qué causa la pérdida temporal de alnetworkingedor de 20 GB de espacio en el disco duro al usar XCode?
  • Mapeo / plugin de Vim para Xcode
  • ¿Cómo cambiar 2 properties en Xcode 4?
  • Encuentro esto confuso: ¿por qué la aplicación se muestra dos veces y hay una forma de eliminar la versión que no funciona?

    Para complicar aún más las cosas, tengo una carpeta Developer-3.2.4 contiene esta versión de Xcode que también se muestra en los resultados de Spotlight. Seguí un tutorial para mantener una versión anterior de Xcode cuando se lanzó la nueva versión 4 con errores. ¿Asumo que puedo eliminar eso de forma segura ahora?

  • Mapeo / plugin de Vim para Xcode
  • ¿Cómo cambio el cursor i-beam del mouse en Xcode 7.3?
  • La descarga de xcode 4 no se completa correctamente
  • ¿Cómo puedo lanzar un escáner de impresora desde Spotlight?
  • ¿Por qué App Store piensa que Xcode 4.2 está instalado?
  • ¿No se supone que XCode es gratis?
  • One Solution collect form web for “Aplicaciones / Xcode vs Desarrollador / Aplicaciones / Xcode”

    Parece que actualizaste tu sistema con versiones anteriores de Xcode y no instalaste Xcode 4.2 mientras instalaste Xcode 4.3.

    Xcode desde la versión 4.3 en adelante se instala en /Applications . Solo las versiones anteriores (como su Xcode 4.2) se instalan en /Developer . Si no planea iniciar OS X Lion desde otro disco / partición y usa Xcode 4.2, puede desinstalarlo de manera segura (no solo elimine la carpeta del Finder).

    Para desinstalar Xcode 4.2:

    1. Abrir terminal ( Applications -> Utilities -> Terminal.app )
    2. Escriba el command sudo /Developer/Library/uninstall-devtools --mode=all

    Para desinstalar tu Xcode 3.2.4 en / /Developer-3.2.4 3.2.4:

    1. Abrir terminal ( Applications -> Utilities -> Terminal.app )
    2. Escriba el command sudo /Developer-3.2.4/Library/uninstall-devtools --mode=all

    Referencia: Cómo eliminar Xcode de tu Mac

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).